All Oracle Error CodesOracle DBA Forum

ORA-01096:

program version (string) incompatible with instance (string)
Cause: A program is trying to connect to an instance using a different version of code than the database was started with. This is not allowed.
Action: Either relink the program with the same version as the database or restart the database using the old version of code.